At Playvox we are constantly looking to improve and offer the best experience, system performance and security possible. Which is why our platform has been designed and tested to work across major modern Internet browsers. 

In order to access Playvox, you will need to use a modern up-to-date web browser with JavaScript, Cookies and TLS 1.2 enabled. 

The following is a list of our supported web browsers: 

Note: Our TLS 1.0 support ended on June 30th, 2018. The browsers listed below will not work since they do not support TLS 1.1 or higher by default. 

  • Internet Explorer 10 or earlier.
  • Google Chrome 29 or earlier.
  • Mozilla Firefox 26 or earlier.
  • Opera 16 or earlier.
  • Safari 8 or earlier.

For more information please refer to the following article: http://help.playvox.com/end-of-support-for-tls-10-encryption-protocol

If you are currently using IE 11, we recommend you switch to another supported browser, especially since we will end all support related to it by August 31, 2020. After this date Playvox won't work anymore on IE 11.

More information on removal of support for Internet Explorer 11

Last Edited: 03.18.2020

Did this answer your question?